Документация

Поддержка jQuery

Начиная с версии 1.2, JavaScript API по умолчанию включает библиотеку jQuery 1.3.2. Соответственно, разрабатывая код с использованием JavaScript API, дополнительно подключать библиотеку jQuery не требуется.

Если есть необходимость подключить одну из предыдущих версий библиотеки jQuery, подключите файл JS API без jQuery. Файл доступен по адресу: http://img.yandex.net/webwidgets/{version}/WidgetApi_no_jquery.js.

Например, для использования jQuery 1.2.2:

<html>
  <head>
    <script type="text/javascript" src="jquery-1.2.2.js"></script>
    <script type="text/javascript" src="http://img.yandex.net/webwidgets/1/WidgetApi_no_jquery.js"></script>
    ...
  </head> 
  <body />
</html>

Яндекс.Виджеты jQuery