Документация

Обновление устаревшего браузера

Карты Яндекса используются на многих сайтах — реализуется это с помощью специального интерфейса, API. Если вы оказались на этой странице, скорее всего, ваш браузер устарел. Для корректной работы карты, пожалуйста, обновите свой браузер или установите последнюю версию другого современного браузера.

API Яндекс.Карт полностью совместим с последними версиями следующих браузеров:

Кроме того, частично поддерживаются следующие браузеры:

  • Microsoft Internet Explorer версий 8-10;
  • Opera версии 12;
  • AndroidBrowser версий 4.0+.

В этих браузерах доступна та функциональность API Яндекс.Карт, которую технически возможно реализовать на данной платформе. Например, в Internet Explorer невозможно задать произвольные цвета для меток, из-за того что в браузере нет полноценной поддержки SVG (масштабируемой векторной графики). Кроме того, графические объекты и элементы управления в этих браузерах могут выглядеть иначе, чем в современных браузерах.

Мы стараемся поддерживать совместимость даже с устаревшими браузерами, но со временем это становится все сложнее, потому что веб-технологии и стандарты, которые необходимы для корректной работы API, отсутствуют в браузерах прошлого поколения. Более того, их использование небезопасно, поэтому мы настоятельно рекомендуем переходить на современные и регулярно обновляющиеся браузеры, лучше защищенные от вирусов и позволяющие полноценно работать с современными сайтами и веб-сервисами.